Wahyu Widagdo pada 22 April 2018

Saya sedang mengikuti tutorial Ruby on Rails. Setelah saya instal Rails dan membuat project baru. Saat saya menjalankan Rails server muncul error seperti judul di atas
Could not find gem 'mysql2 (< 0.6.0, >= 0.4.4)' in any of the gem sources listed in your Gemfile.
Run bundle install to install missing gems.

Saya sudah menjalankan perintah : "sudo apt-get install libmysqlclient-dev"
Lalu saya jalankan lagi rails server, namun tetap muncul error tsb.

Agung Setiawan pada 22 April 2018

Setelah sudo apt-get install libmysqlclient-dev udah jalanin bundle install ?
Kalau belum, coba dulu itu terus lanjut jalankan server

Wahyu Widagdo pada 22 April 2018

Sudah mas, akhirnya bisa jalankan rails server. Tetapi setelah itu muncul error

Mysql2::Error::ConnectionError (Access denied for user 'root'@'localhost' (using password: NO))

Mohon ma'af kalau merepotkan mas

Agung Setiawan pada 22 April 2018

Kalau itu beda error lagi. Itu setting database di Rails-nya ga pas
Buka config/database.yml terus sesuaikan

Setting-an default-nya user: root dan ga pakai password

Wahdan pada 09 Oktober 2018

saya juga mengalami msalah yang sama saat menjalankan perintah "rails s" muncul pesan error seperti di atas. namun sy menjalan kan di MacOs. klau di mac os gimana solusinya mas? makasih.

Agung Setiawan pada 10 Oktober 2018

Sudah install mysql Mas?
Harusnya di mac kalau sudah insyall mysql ga ada masalah